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1. Welcome! 
 

Welcome to the simplified user manual for the Biopac® Student Lab PRO® software. This 

manual has been specially written for students who participate at the medical physics laboratory 

practices at the University of Szeged, Hungary. It contains all the information that you will need 

for being prepared for handling the Biopac® Student Lab PRO® software. This document is built 

up step-by-step, and contains cross-references for the parts which you may need to complete a 

specific task. Important: this manual is intended to be used together with the syllabi of the 

laboratory practices! 

 

Though the Biopac® Student Lab PRO® software is not available for free, you can download the 

Biopac® Student Lab Analysis software for free, which has (almost) all of those features, which 

you will need for being prepared for the laboratory practices. To do so, you will have to register 

(or log in, if you already registered) at the http://www.biopac.com/BSL-Analysis.asp site. 

Registration is totally free. To review the similarities and differences between the two softwares, 

please refer to section 9 ‘Similarities and differences between Biopac® Student Lab PRO® and 

Biopac® Student Lab Analysis’. 

  

http://www.biopac.com/BSL-Analysis.asp
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3. User interface of the Biopac® Student Lab PRO® 
 

3.1. Starting the Biopac® Student Lab PRO® 

 

To start the Biopac® Student Lab PRO®, first, find the icon of BSL PRO, and then double-click 

on it. The software might indicate that there is no MP36 unit connected to the computer. 

 

 
 

If this happens, do not worry, just click on the ‘Analyse only’ button. 

 

3.2. Familiarize yourself with the user interface of the Biopac® Student Lab 

PRO® 

 

Right after startup, the main window of the Biopac® Student Lab PRO® looks like the image 

below. It can contain one… 
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…or even more measurement windows. 
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Each measurement windows have their own selection, magnification and measurement tools (see 

section 4.4.1 ‘Selection, control, and navigation tools of measurement windows’ and 4.4.2 

‘Channels and measurements’). 

 

3.2.1 Menu structure of the main window 

 

The main menu consists of seven menu points, which contain a variety of sub-menus. Some sub-

menus contain more sub-menus. This is denoted by the  symbol right to the name of the sub-

menu. In the further parts of this manual, the menu points are type casted in bold italic style, and 

the navigation in the menu is denoted by the → symbol, e. g. File → Open… means that you 

should click on the ‘File’ in the main menu, navigate to ‘Open…’, and click on it. 
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In the File menu, you can find 

functions which can help you in the 

general handling (opening, closing, 

saving, etc.) of measurement 

windows. 

In the Edit menu, you can find useful 

tools for the general handling of 

waveforms (curves). 

In the Transform menu, you 

can find a variety of 

transformation functions, 

which can help in the post-

processing and evaluation of 

signals. 

The Display menu makes one 

able to modify the display 

properties of waveforms 

(curves). 
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In the Window menu, you can 

arrange the measurement 

windows. 

In the MP36 menu, one can 

set up the properties of 

acquisition. 

In the Help menu, you 

can find the whole 

detailed help material 

of the Biopac® 

hardware, software, 

and toolkits. 
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4. Opening, evaluating and saving measurements 
 

4.1. Opening measurements 

 

Go to File → Open…, and then select the file in the dialogue window. There are basically 2 file 

types, which you will use:  

- ACQ: Acquisition file; this is the standard file type of Biopac® Student Lab PRO® 

- Ldd: Lesson file; you will also frequently use this file type, especially if you have to 

perform measurements during the laboratory practice 

 

4.2. Saving measurements 

 

To simply save a measurement, go to File → Save. If you would like to save your measurement 

with another name, go to File → Save as…, then select the folder which you would like to use 

for saving and type a name for your file. 

 

4.3. Measurement windows 

 

A measurement window can contain one or more waveforms. A waveform is actually a curve. 

Normally, each waveform is presented in its own channel. In the figure below there are five 

waveforms in five channels. 
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Each channel has its own vertical scale, however, they share a common horizontal scale. This is 

very important to keep in mind, since magnification (4.4.1 ‘Selection, control, and navigation 

tools of measurement windows’) only affects the vertical scale of the channel of the magnified 

waveform, however, it modifies the horizontal scale of all channels, and, as a result, modifies the 

appearance of all waveforms. 

 

4.4. Evaluating measurements 

 

4.4.1 Selection, control, and navigation tools of measurement windows 

 

The most basic tools of the measurement window can be found in its right lower corner. The 

 buttons control the behaviour of the cursor during work. 
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By pressing , you can easily navigate throughout the waveforms (curves). This tool becomes 

handy if you select a part of the waveforms, and you want to review another part of the registered 

data, and you would like to preserve your selection. 

 

By pressing , you chose the selection mode. If you click and draw with the cursor, you can 

select a specific part of the waveforms. 

 

 
 

As a result, you can perform measurements within the marked area, which are, in this sample 

image, the minimum and maximum values of the red waveform, and the last value of the 

selection, respectively (4.4.2 ‘Channels and measurements’). 
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The  button activates zoom selection mode. In this mode you can zoom (magnify) a specific 

part of a waveform. To do so, simply select that part of the waveform (by clicking and drawing), 

which you would like to magnify. This tool becomes useful if you have to precisely mark a tiny 

range of the waveforms. If you get lost, use the  and  buttons in the main toolbar (in this 

order). Please refer to 8.1 ‘Toolkit buttons of the main window’. Alternatively, you can right-

click on the waveform, and select ‘Zoom back’ as many times as needed.  

 

4.4.2 Channels and measurements 

 

To perform a measurement, you have to use the measurement toolbar: 

 

 
 

To define the measurement, that you would like to perform, first choose the channel by clicking 

on the channel selection button, then, click on the channel, that you would like to use. 
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To define the measurement that you would like to perform, click on the measurement selection 

button and select the measurement. 
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There are several types of measurement: 

 None: no measurement is performed 

 Value: the actual value of the waveform at the cursor (or at the end of the selection) 

 Delta: the difference between the values of the waveform at the beginning and the end of 

the selection 

 P-P: peak-to peak; the difference between the maximal and the minimal value of the 

waveform within the selection 
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 Max: the maximal value of the waveform within the selection 

 Min: the minimal value of the waveform within the selection 

 Mean: the average of the values of the curve within the selection 

 Stddev: the standard deviation of the values of the curve within the selection 

 Integral: the sum of the values of the curve within the selection 

 X-axis: T: the horizontal position of the cursor (or the end of selection) 

 Delta T: the horizontal difference between the end and the beginning of the selection 

 T @ Max: the position of the maximum of the curve within the selection 

 T @ Min: the position of the minimum of the curve within the selection 

 

The measured value can be seen right to the measurement selection button. Please keep in mind 

that most of the measurements function only if a part of the waveforms is selected. However, the 

‘Value’ and the ‘X-axis: T’ measurements show the value at the cursor or at the value of the last 

point of the selection. 
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5. Markers 
 

Markers are very useful either if a signal should be divided into multiple parts, or, if some events 

have to be indicated. The marker area is in the top section of the measurement window. 

 

 
 

Normally, the position of the marker is indicated by . However, if a marker has been selected, it 

its symbol is turning to . The text area shows the name of the selected marker. The  and  

buttons can be used for stepping through the markers one by one. By pressing , one can open 

the marker menu. 
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Try these buttons and see what happens. 
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6. Recording 
 

6.1. Performing recordings 

 

The  indicator shows if the system is able to perform a recording. If there is no MP36 unit 

connected to the computer, this area looks like . 

 

By pressing the  button, you can start recording with the MP36 unit. During recording, 

the indicator turns to , indicating that there is a communication between the computer and the 

MP36 unit. 

 

If you would like to stop the recording, simply press . By pressing  again, you can 

continue the recording. 

 

6.2. Calibration 

 

To calibrate the system, first perform a short period of recording. Then, click on the numbers to 

the right of the channel. 

 

 
 

Then, click on Scaling… in the window. 
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Finally, click on Cal1 and Cal2. 

 

 
 

6.3. Placing markers 
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During recording, you can place markers by clicking below the text area. 

 

 
 

After that, you can type the name of the marker in the text area. 
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7. Data manipulation 
 

7.1. Basic operations with waveforms and channels 

 

This chapter describes the basic steps, which you can use for the evaluation. This information can 

be useful if you have to modify a waveform to be able to perform a specific measurement. 

 

7.1.1 Duplicating waveforms 

 

To duplicate a waveform, first select it by clicking on its name. 

 

 
 

Then, right-click on the waveform (not the name of the waveform), and select Duplicate from the 

local menu. Alternatively, you can click on Edit → Duplicate waveform. This function becomes 

useful if you have to create a derivative of a waveform (e. g. the purple waveform is the derivate 

of the red one). 

 

7.1.2 Renaming channels 

 

To rename a channel, double-click on its name, then, type the new name of the channel in the 

window. 

 

 
 

7.1.3 Changing the unit of the vertical axis’ 

 

To change the unit at any of the vertical axis’, double-click on its unit. 
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Then, type the new unit in the window. 

 

7.1.4 Rescaling the horizontal axis 

 

In many cases, the original scaling of the axis’ can be inconvenient. To change the scaling of the 

horizontal axis, click on one of the numbers along it. 

 

 
 

Then, modify the parameters in the window. 
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In this case, an upper limit of 45 seconds, and a major division of 5 seconds could be more 

convenient. Try changing the original settings and see what happens. 

 

7.1.5 Rescaling the vertical axis’ 

 

To change the scaling of any of the vertical axis’, click on one of the numbers along it, then 

modify the parameters in the window. 
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Note that you can also apply your modifications to all the vertical axis’ by marking the ‘All 

Channels’ field. Try changing the original settings and see what happens. 

 

7.1.6 Removing waveforms 

 

To remove a waveform, first select it by clicking on its name. Then, click on Edit → Remove 

waveform. Use this function carefully! 

 

7.1.7 Clearing waveforms 

 

Clearing a waveform means that it is going to be filled up with zeros. To clear some part of a 

waveform, mark it with the selection tool (4.4.1 ‘Selection, control, and navigation tools of 
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measurement windows’), then click on Edit → Clear. By clicking on Edit → Clear All you can 

clear the entire waveform. Use this function carefully! 

 

7.2. Transformations: advanced tools for data manipulations 

 

7.2.1 Smoothing 

 

In some cases the signal contains a considerable amount of noise. In such cases, the detection of 

peaks or any given values (e. g. 70% of the maximum, etc.) in the signal can be difficult. By 

smoothing the waveform, one can suppress the noise, and as a result, the maxima and minima, as 

well as any given values can be clearly detected. To perform the smoothing of a waveform, select 

the waveform by clicking on its name, then click on Transform → Smoothing… After that a 

window appears with the settings of the smoothing. 

 

 
 

During smoothing, one point of the waveform is being replaced by the mean or the median of the 

points around it. The number of points, which are involved around a given point, is given by the 

Smoothing factor. 

 

Be aware of that if you select some part of the waveform prior to smoothing, the process will be 

performed only in the selected region. To perform smoothing throughout the entire waveform, 

make sure that the ‘Transform entire waveform’ is selected. 

 

7.2.2 Filtering with low-pass filter 

 

In some cases, a low-frequency signal contains a high-frequency noise (or a high-frequency 

component, which is disturbing or not relevant). In this case, the high-frequency components 

have to be removed. This can be done by the use of a low-pass filter: click on Transform → 

Digital Filters → IIR → Low-pass… After that, you can set the parameters of the filtering in the 

appearing window. 
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Here, all the frequencies are being removed above the given frequency value.  

 

Be aware of that if you select some part of the waveform prior to filtering, the process will be 

performed only in the selected region. To perform filtering throughout the entire waveform, make 

sure that the ‘Transform entire waveform’ is selected. 

 

7.2.3 Filtering with high-pass filter 

 

In some cases, a high-frequency signal contains a low-frequency noise (or a high-frequency 

component, which is disturbing or not relevant, e. g. the electric signal of breathing in the ECG). 

In this case, the low-frequency components have to be removed. This can be done by the use of a 

low-pass filter: click on Transform → Digital Filters → IIR → High-pass… After that, you can 

set the parameters of the filtering in the appearing window. 

 

 
 

Here, all the frequencies are being removed below the given frequency value.  
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Be aware of that if you select some part of the waveform prior to filtering, the process will be 

performed only in the selected region. To perform filtering throughout the entire waveform, make 

sure that the ‘Transform entire waveform’ is selected. 

 

7.2.4 Fourier transformation 

 

Performing Fourier transformation of a signal, which is represented in time, results in a signal 

represented in frequency. This means that it makes one able to see the frequencies in the signal, 

and how strong they are. To perform the Fourier transformation of the signal, click on Transform 

→ FFT… (FFT is Fast Fourier Transformation, an optimized version of Fourier transformation 

for computers). After that, you can set the parameters of the transformation in the appearing 

window. 

 

 
 

Most of the settings are set right, and should not be modified. However, the scaling of the result 

might have to be modified, depending on the application. 

 

 
 

The result of the calculation is presented in a new measurement window. The vertical scaling 

depends on the previous setting. 

 

- dB: 

 



Simplified user manual for the Biopac Student Lab softwares 

28 

 
 

- Linear: 
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The list of measurements, which can be performed in the measurement window of FFT are a little 

bit different than in the case of normal measurement windows (4.4.2 ‘Channels and 

measurements’). 

 

 
 

The difference is basically because the horizontal axis in this case is the frequency axis, instead 

of time ( ‘X-axis: F’, ‘Delta F’, ‘F @ Max’, ‘F @ Min’), however, their function remains very 

similar. 
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8. Customization of the appearance of the information 
 

8.1. Toolkit buttons of the main window 

 

There are several buttons in the toolbar just below the main menu. With these buttons you can 

customize the visible parts of the measurements and the appearance of the waveforms. 

 

 
 

The  buttons control the display of the waveforms (curves). Try them, and see 

what happens! If you would like to restore the original arrangement of waveforms, please make 

sure that only the  button is pressed in. 

 

The  buttons control the scaling of the waveforms. The most important ones 

of them are the  and  buttons for you, which help you in seeing the whole waveform 

vertically and horizontally, respectively. You will frequently use them, since they can help you 

out of trouble if accidental or improper use of the zoom tool (4.4.1 ‘Selection, control, and 

navigation tools of measurement windows’) happens . 

 

The  buttons help you in finding peaks. 

 

 shows or hides gridlines. 

 

 shows or hides the types and results of measurements. Always make sure that the types and 

results of measurements are visible, since they show essential information for the evaluation of 

the measurements! 

 

 shows or hides the channel selection area. 

 

 shows or hides the marker area. Always make sure that the marker area is visible, since it 

contains important information for the evaluation of the measurements! 

 

 shows or hides the journal. 

 

Try these buttons and see what happens! 
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9. Similarities and differences between Biopac® Student Lab 

PRO® and Biopac® Student Lab Analysis 
 

Biopac® Student Lab Analysis has several restrictions with respect to. This chapter describes the 

differences between the two softwares. The user interface of the Biopac® Student Lab Analysis 

can be seen below. 

 

 
 

9.1. Similarities 

 

Biopac® Student Lab Analysis has all those functions as Biopac® Student Lab PRO®, which are 

described in 4 ‘Opening, evaluating and saving measurements’, 5 ‘Markers’, and 6 ‘Recording’. 

Some functions, which are described in 7 ‘Data manipulation’ can be also used, namely, you can 
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rescale the waveforms both horizontally and vertically (7.1.4 ‘Rescaling the horizontal axis’ and 

7.1.5 ‘Rescaling the vertical axis’’). 

 

9.2. Differences 

 

The first and most salient difference is the absence of the tollbar. Instead of the toolbar, there are 

only 4 buttons. 

 

 
 

Try them and see what happens. 

 

The next significant difference can be found in the menu structure: there are much less options. 

Do not worry, most laboratory practices do not require the missing functions, so you can prepare 

well for them even by the use of Biopac® Student Lab Analysis. 

 

Another minor difference is that only allows one measurement to be opened. 

 

9.3. Restrictions 

 

Unfortunately, Biopac® Student Lab Analysis is not able to perform most of the utilities, which 

are described in 7 ‘Data manipulation’. Though these will be needed during some practices, you 

will be able to perform the required measurements, if you learn handling Biopac® Student Lab 

Analysis. 

 

Another minor restriction is that only allows one measurement to be opened. 
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